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1 Introduction 

BlomURBEX is a collection of Web Services provided by Blom that allow to 

navigate through high-detailed maps with ortho and oblique imagery, and to fly 

through 3D immersive cities. In addition, the Web Services can be invoked to 

obtain measurement information about buildings and other map elements. 

Blom leverages in Europe and around the world the production of a huge image 

and 3D model database of more than 900 cities, and the database increases each 

month as new countries are included in it. BlomURBEX offers the most detailed 

and comprehensive imagery database and 3D models of urban places in the 

market. 

Based on the same interface, Blom is developing a full range of plug-ins that 

integrates BlomURBEX services in common GIS and CAD applications. Blom 

development roadmap with BlomURBEX includes the following targets: 

 

 BlomURBEX plug-in for ESRI ArcMap (ArcView, ArcEditor and ArcInfo) 

 BlomURBEX plug-in for ESRI ArcIMS 

 BlomURBEX plug-in for ESRI ArcGIS Server 

 BlomURBEX plug-in for Intergraph GeoMedia Professional 

 BlomURBEX plug-in for Integraph GeoMedia WebMap 

 BlomURBEX plug-in for Autodesk Map and AutoCAD 

 BlomURBEX plug-in for Autodesk MapGuide 

 BlomURBEX plug-in for Bentley MicroStation 

 BlomURBEX plug-in for MapInfo Professional 

 BlomURBEX plug-in for MapInfo MapXtreme 

 

Contact Blom at http://www.blomasa.com/contact.html for new releases and 

updates. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

http://www.blomasa.com/contact.html
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2 Version changes 
 

Version 3.0.0 of BlomURBEX Plug-in for Autodesk Map 

2010/2011/2012/2012 these improvements: 

 

 Added support for adding Blom Library as a data source. 

 ―Display measurement tool results‖ option has been removed from 

―Printing‖ options in ―Settings‖. 

 Better navigational controls for map. 

 Proxy settings will now get detected automatically. 

 

Version 2.5.2 of BlomURBEX plug-in for Autodesk Map 2010/2011 

includes these improvements: 

 

 Fixed an error that causes a crash in Autodesk Map when viewing obliques. 

 OSGB36 projection supported. 

 Fixed a problem for viewing overlays in one view of multi-view layouts. 

 Fixed a problem refreshing overlays in obliques. 

 NTLM and Kerberos proxy authentication support 

 

Version 2.5.1 of BlomURBEX plug-in for Autodesk Map 2010/2011 

includes these improvements: 

 

 Better support for big geometries in overlays 

 

Version 2.5 of BlomURBEX plug-in for Autodesk Map 2010/2011 includes 

these improvements: 

 

 All the rendering is done asynchronously. 

 Height measurement now uses a BlomURBEX service to obtain the best 

angle in the oblique image to force the measurement in a vertical direction. 

 Better resize to avoid flickering. 

 Vector overlay on top of oblique imagery is done faster. 

 A new option in settings can change the priority order for the basemap. 

Now it is possible to priorize between the different ortho images (―pictometry‖, 

―countryortho‖ or ―satellite‖) present sometimes at the same zoom level in the 

server. 

 Other tile layers in BlomURBEX server can be overlapped selecting them in 

the options dialog. 

 Product and version number appears in About dialog. 

 Print error that occurred after printing is fixed. 

 Tooltips close when the map looses focus. 

 Default zoom and orientation has been fixed. 

 Views are now correct when changing between different layouts. 

 Bug fixed with double sync between map and BlomURBEX viewer. 

 Bug fixed with Extract image tool. 

 Proj4 DLL is no more used, but DotSpatial is used instead. 

 Installer uses bootstrap to download from web required prerequisites. 

 More accurate measurements in distance and area. 
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Version 2.0 of BlomURBEX plug-in for Autodesk Map 2010/2011 includes 

these improvements: 

 

 Internet Explorer 7 not needed. New BlomURBEX viewer do not requires 

Internet Explorer 7 to be installed or any other web browser. The plug-in manage 

requests on its own. 

 A new image cache owned by all the plug-ins speeds bitmap recovery and 

makes it easy to manage the plug-ins cache. No more the browser cache is used. 

 Easier installation. BlomURBEX viewer component is not a previous install 

requirement. Plug-in installer checks if viewer is installed, and if not, then installs 

it. The viewer is never uninstalled to avoid other plug-ins to stop working. 

 Better performance. New BlomURBEX viewer is not JavaScript based but 

.NET based, and executes code faster. 

 New option to choose the date of the imagery, allowing to see history 

changes in images, and seeing different years in a side-by-side mode. 

 Year of the current visible image in a label at the bottom of each view. 

 Intelligent behaviour when zooming. If a better view mode or orientation 

exists for current zoom then it is loaded automatically. 

 Faster vector overlay on obliques. The new BlomURBEX viewer sends 

fewer requests to transform vector data between ortho and oblique, and draws 

vector data faster. 

 A new button in toolbar to enable/disable vector overlay faster than 

changing settings. 

 Print improvement. Print and export now support vector overlay. 

 Log levels to better grained logging and a default folder for storing logs in 

just one file. 

 A new tool for extracting images has been added. If image exported is 

ortho view, then the world file is saved for easy use in GIS packages. 

 Proxy settings support 

 Full support of Windows versions from XP to 7, including 32 and 64 bits 

versions. 
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3 System requirements 
 

Microsoft .NET Framework 2.0 and 3.5 (installed by setup if not present) 

 

BlomURBEX plug-in for Autodesk Map 2010/2011/2012 is developed with 

Microsoft .NET Framework 2.0 and 3.5. During installation, if these Frameworks 

are not present, they are downloaded and installed. 

 

Autodesk Map version 2010/2011/2012 

 

This BlomURBEX plug-in for Autodesk Map 2010/2011/2012 requires any of these 

products from Autodesk installed in order to execute BlomURBEX plug-in. 

 

Windows versions 

 

BlomURBEX plug-in for Autodesk Map 2010/2011/2012 supports Windows 

versions supported by the Autodesk product. Read Autodesk Map 

2010/2011/2012 install guide for more info. 

 

User Token 

 

To access BlomURBEX Web Services a UserToken is needed. This UserToken is an 

encrypted string that authenticates each user request. Contact with Blom 

Marketing Department to obtain the required UserToken in: 

 

http://www.blomasa.com/contact.html 
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4 Installing BlomURBEX plug-in for Autodesk Map 
2010/2011/2012 
 

1. Ensure you are logged onto your computer with Administrator privileges. 

2. Close all programs. 

3. Uninstall previous ―BlomURBEX plug-in‖ versions for any GIS or CAD package that 

could be installed. Older ―BlomURBEX plug-ins‖ cannot coexist with current 

version. If any other plug-in is installed for other GIS or CAD package, upgrade 

the plug-in also to last version. 

4. Run setup.exe installer. Be careful to not run Urbex30AutodeskMap2010.msi 

installer because this installer does not check if dependencies are already 

installed. 

5. If .NET Framework 2.0 or .NET Framework 3.5 are not installed a message is 

shown. Accept in the message. The Frameworks will be downloaded from the 

Microsoft webpage and installed. 

6. If Microsoft Interop Forms is not installed a dialog will appear to perform its 

installation. Click in Accept to accept the license agreement and continue. This 

software from Microsoft is an add-in to the .NET Framework that improves 

ActiveX / .NET interoperability. 

 
7. Wait until Microsoft Interop Forms install completes. 
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8. The BlomURBEX plug-in for Autodesk Map 2010/2011/2012 Setup Wizard will 

lead you through all stages of the setup process. 

 
9. Click Next > to begin installation. 
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10. The next screen displays the license agreement. Please read this and if you 

accept the terms select the ―I Agree‖ radio button. Click Next > to continue. 
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11. Click Browse to change the destination folder. Click ―Disc cost‖ to confirm that 

there is enough space to install. Select in the radio buttons if BlomURBEX plug-in 

for Autodesk Map 2010/2011/2012 will be available to all users or just you in 

your computer. Click Next > to continue. 

 
12. Click Next > to start installation. 

13. Finally click Finish to close installation wizard. 
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5 Starting with BlomURBEX plug-in for Autodesk Map 
2010/2011/2012 

5.1 Setup the BlomURBEX Viewer plug-in in Autodesk Map 
2010/2011/2012 

To execute the plug-in, follow these steps: 

1. Open Autodesk Map 2010/2011/2012. 

2. Select the Tools > Load application menu. The ―Load / Unload applications‖ dialog 

box will open. 

 
3. Browse for the accont2010.arx file contained in the plug-in install folder, select it, 

and then click the Load button. This ARX application is an utility that allows 

dockable windows inside Autodesk Map 2010/2011/2012. It should appear in the 

bottom list of loaded applications, as shown in the screenshot. 

4. To avoid this setup every time Autodesk Map is started, click in the Contents 

button. The ―Load on startup‖ dialog box will appear. 
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5. Click the Add button. A new dialog will open. Browse to the accont17.arx file in 

the plug-in install folder, select it, and click Add. Then Close the ―Load on startup‖ 

dialog and the ―Load / Unload applications‖ dialog. 

6. To load the Blom Dockable Window that contains the BlomURBEX Viewer, type 

with the mouse cursor inside Autodesk Map or type in the command bar if visible 

the following command: dockable_container and press Enter. 

 
7. The command executes and asks for a ProgID (the identifier of the dockable 

control that shows BlomURBEX Viewer). Type the following identifier: 

BlomUrbexDock2010.DockControl, and press Enter. After some seconds, the 

BlomURBEX Viewer will be opened in a dockable window inside Autodesk Map 

2010/2011/2012. 

 
8. It is possible to dock or undock the window as with any Autodesk Map dockable 

window. Also it is possible to reduce the window to a sidebar clicking in the 

buttons that appear on top and title bar of the window. Also the window can be 

closed. To open it again repeat steps 6 and 7. The window saves its state when 

Autodesk Map is closed so next time it will be seen the same as previously. 
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5.2 Adding Data Sources 

A Data Source is a repository of complex cartographic data. In order to work with 

a Data Source it must be assigned to Plug-in. 

Current version of Plug-in supports two different Data Sources: 

 

1. BlomURBEXTM online services 

2. Blom Libraries 

 

5.2.1 Adding BlomURBEXTM as a Data Source 

1. In the BlomURBEX Viewer toolbar, select the menu Settings > Open 

settings dialog, to open the Settings dialog. 

2. In the dialog select General tab. 

3. In the Data Source drop down select ―BlomUrbex‖. 

 
4. In the ―User token‖ textbox type the UserToken provided by Blom. This 

UserToken is an encrypted string that authenticates each user request. 
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Contact with Blom Marketing Department to obtain the required 

UserToken. The UserToken is needed to connect to the BlomURBEX Web 

Services and allow the access to the imagery. 

 
5. Click OK button to finish configuration. 

 

5.2.2 Adding Blom Library as a Data Source 

1. In the BlomURBEX Viewer toolbar, select the menu Settings > Open 

settings dialog, to open the Settings dialog. 

2. In the dialog select General tab. 

3. In the Data Source drop down select ―Blom Library‖. 

 
4. Selecting Blom Libraries 

 Browse and select a Blom Library. 

 Click ―add new‖ button in order to add multiple libraries. 

5. Selecting Library Licenses 

 Browse and select a valid License. 

 Click ―Add New‖ button in order to add multiple licenses in case 

there are more than one library. 

6. In order to remove a Library or a License, click delete button next to it. 
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7. Click OK button to finish configuration. 

5.3 Setup the BlomURBEX Viewer basic options 

The first thing to do in an application that uses BlomURBEX Viewer is to specify 

some minimum options in order that the viewer can correctly search for images. 

For this follow the next steps. 

1. Open BlomURBEX Viewer window using the dockable_container command 

as explained above. 

2. In the BlomURBEX Viewer toolbar select the menu Settings > Open 

settings dialog to open the Settings dialog. 

 

 

3. In the dialog select the General tab. Select the desired Data Source (See 

section 5.2 for details on adding a Data Source).  

4. Select the Linking tab. Depending on the projection of the basemap (the 

map of Autodesk Map 2010/2011/2012) it is needed to indicate BlomURBEX 

Viewer which projection is this. Follow next steps. 
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5. Click in the Select button to open the ―Select projection‖ dialog. In the 

dialog select in the available projection list the one that the basemap has. There 

are different options to select the desired projection: 

6. To select a projection from the full list of supported projections, choose 

―Show all projections‖ in the upper dropdown box. To select click in the list and 

then click in OK, or double click an item in the list. Any item chosen will be 

reminded later in a list with the most used projections, so it is not needed to find 

it again in the long list. Also, it is possible to add any item to this ―most used‖ list 

without leaving the dialog clicking with right mouse button and selecting ―Add to 

most used‖ from the context menu. 
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7. To select a projection from the reduced list of the most used projections, 

choose ―Show most used projections‖ from the upper dropdown box. The list will 

show only those projections selected at least once or any other marked explicitly 

as ―most used‖. To select click in the list and then click in OK, or double click an 

item in the list. Alternatively, it is possible to remove items from this ―most used‖ 

list clicking with the right mouse button and selecting ―Remove from most used‖. 

The current selected projection cannot be removed from this list. 
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8. To select a projection from a reduced list using a filter, choose ―Use a 

filter‖ in the upper dropdown box. The filter textbox and Filter button will 

activate. Type a search word or words in the filter textbox and press Filter. Only 

the projections containing the full search text will be shown. The search is 

possible by EPSG code and also by the projection name, and is case insensitive. 

To select click in the list and then click in OK, or double click an item in the list. 

The selected projection will be recorded in the ―most used‖ list as usual. 

 
9. Save the settings clicking in OK. Settings are saved in registry for each 

user so it is not needed to set them again later as each user has their own 



 
BlomURBEX™ Plug-in for Autodesk Map 2010/2011/2012 v3.0.0 

 

 17 

Blom, ASA. Proprietary 

settings. The latest settings are used by default. To configure different settings 

use the Save button to save a file with the settings that can be later opened with 

the Open button. 

10. This finish the configuration. 

 

 

Settings do not persist, if the Plug-in is reinstalled. We need to set the settings 

again in case of re-installation. 

 

5.4 Changing language interface 

Language interface can be changed through the direct menu: Settings > 

Language, or through the Settings dialog, by Settings > Open Settings dialog. 

The first is a more direct way to change the language, but the results are the 

same. 

To change the language through the direct menu: 

1. Click in menu Settings > Language > <The desired language>. The 

interface language of the application is changed at once. The selection is saved in 

the user registry so next time BlomURBEX Viewer is opened the preferred 

language will remain in the interface. 

 

To change the language through the settings dialog: 

1. Click in menu Settings > Open settings dialog. 

2. Select the General tab. In the Language selector, choose the preferred 

one. The interface language of the application is changed at once. 

3. If needed, click Save to save the settings in a file for future use. 

4. Click OK to save the settings in user registry. Next time BlomURBEX 

Viewer is opened the preferred language will remain in the interface. 

Improving translations of the interface is very easy. Check the Appendixes. 
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5.5 Changing layout 

BlomURBEX Viewer can show one or several orientations at the time using 

different layouts, and view images of different dates. It is possible to change from 

one layout to other either from Settings > Layout direct menu, or using the 

Settings dialog by Settings > Open settings dialog menu. The first is a more 

direct way to change the layout, but the results are the same. 

To change the layout using a direct menu: 

1. Click in Settings > Layout > <the desired layout>. The choice is saved in 

the user registry so this layout will remain in future sessions until changed again. 
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To change the layout and image dates using the settings dialog: 

1. Click in Settings > Open settings dialog menu to open settings dialog. 

 

 
2. In the dialog select the Layout tab and select the preferred layout in the 

upper dropdown box. For each view in the layout, it is possible to select the 

preferred year of the BlomURBEX imagery to be shown as explained later. 

3. If needed, click Save to save the settings to disk for future use. 

4. Click OK to save the settings in user registry. Next time BlomURBEX 

Viewer opens the preferred layout will remain in the interface. 
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6 Viewing BlomURBEX images 

The BlomURBEX Viewer is the window that shows BlomURBEX images. To open 

an image is needed to select a location, either clicking in the basemap in 

Autodesk Map 2010/2011/2012 or introducing a known coordinates. 

6.1 Selecting location in Autodesk Map 2010/2011/2012 

1. Open Autodesk Map 2010/2011/2012 with a basemap. 

2. Open BlomURBEX Viewer if it is not, as explained previously. 

3. Ensure that settings are correct, as previously indicated. 

4. Resize and move application windows so they can be seen comfortably. 

5. Open any map data in Autodesk Map 2010/2011/2012. The data can use 

any projection if it is in the EPSG list in the BlomURBEX Viewer options. It is only 

needed to know the projection and to indicate this projection in the BlomURBEX 

Viewer settings dialog. 

 

 

Remember when using different drawing files in Autodesk Map with different 

projections to modify the options in BlomURBEX Viewer matching the active one. 

 

1. Once everything is right set, and with a map drawing opened, click in the ―Center 

in new map point‖ button at the bottom of the BlomURBEX Viewer. Click OK in 

the message that appears and then move mouse cursor over the map display and 

click inside it. A message requesting a point will appear. Type the exact 

coordinates and press Enter or select a point clicking in the map. 

 
2. After some seconds BlomURBEX Viewer will open the best Blom images for that 

location, in all the orientations selected in the BlomURBEX Viewer layout. The 

images are centered in the selected point and show a crosshair. If no image 

appears consider if your user permissions do not allow seeing images for that 

location. 
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6.2 Introducing known coordinates in BlomURBEX Viewer 

1. In BlomURBEX Viewer toolbar click in the tool ―Go to coordinates…‖ . 

The ―Go to coordinate‖ dialog is opened. 

 
2. Introduce a correct longitude or X and latitude or Y coordinates. Indicate 

the projection for this coordinates clicking in Select. This opens the same Select 

projection dialog that we see when selecting the basic options. By default, the 

last projection selected in the Settings dialog is offered here, but it can be 

changed, so we can ask for coordinates in any of the supported projections. 

3. Click OK. 

4. After some seconds BlomURBEX Viewer will open the best BlomURBEX 

images for that location, in all the orientations selected in the BlomURBEX Viewer 

layout. The images are centered in the selected point and show a crosshair. If no 

image appears consider if your user permissions do not allow seeing images for 

that location. 

6.3 Panning images 

―Panning‖ is the default behaviour of the display when no tool is selected. 

1. In BlomURBEX Viewer unselect any tool in the toolbar.  

2. Click and hold the left mouse button in the view to pan. 

3. Drag the image up, down, left, or right within the view, and finally release 

mouse. 

6.4 Magnifying images 

It is possible to zoom in for more detail or zoom out for more context information. 

Simply change the image’s magnification by using the zoom buttons on the 

toolbar. 

Zooming in all views 

Use the ―Zoom In‖ button to increase the magnification of an image. 

To zoom in: 

1. Click the ―Zoom In‖ button on the toolbar . 

2. The magnification percentage is doubled. (The part of the image that was 

centered in the display remains in the center.) . The ―Zoom In‖ button affects all 

the images opened in the layout. 

3. Continue clicking the button until reached the desired amount of 

magnification. 
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Zooming out all views 

1. Click the ―Zoom Out‖ button on the toolbar .  The ―Zoom Out‖ button 

affects all the images. 

2. The magnification is reduced by half. 

3. Repeat Step 1 until zoomed out the desired amount.  

Zooming in or out with the mouse wheel in one view 

 

1. Move the mouse wheel frontwards or backwards to zoom in or out in just 

one view. 

 

Zooming to a extent in one view 

 

1. Unselect any tool selected in the toolbar so the ―Pan‖ default tool 

activates. 

2. Press SHIFT key in keyboard. 

3. Click with left mouse button in any view and hold pressed. Drag to draw a 

rectangle. A rectangle appears showing the extent selected. Release button at the 

ending corner. 

4. Map centers and zoom to the best level zoom that contains the selected 

extent.  This action only affects the view used. 

Zooming with the zoom bar in one view 

 

1. Each view has a zoom bar with a ―+‖ button on top and a ―-‖ button on 

bottom. Click ―+‖ button to increase the zoom level, or ―-‖ to decrease the zoom 

level. There are 20 zoom levels available for the ―continuous‖ or ―Ortho‖ view 

mode (see below about view modes). There are 6 zoom levels available for the 

―photo by photo‖ or ―Oblique‖ mode. The last two levels in ―Oblique‖ mode are a 

resample of level 4. 

2. Alternatively drag the level indicator up or down to increase or decrease 

any number of zoom levels. Every view in the layout has its own level indicator, 

so changes in this only affect the view that contains that level indicator. 
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6.5 Changing views 

Initially each view in the layout has set an orientation, but it is possible to modify 

this selecting orientations orientation selector. In fact, it is possible to have the 

same image several times. For example, it is possible to use the dual view to 

have two times the same ortho image opened. It can be useful to have a master 

– detail view to study two distant buildings at the same time that are in the same 

photo. Each time an orientation is changed in a view; this setting is saved in user 

registry so it will be used until changed again. 

 

There are two types of view modes: ―Ortho‖, that shows the images in a 

continuous mode, and ―Oblique‖, that shows images one by one. In both modes it 

is possible to do ―Pan‖ in the map endlessly. In the Oblique mode a new image is 

loaded in a seamless way when ―panning‖ reaches the border of the current 

loaded image.  

 

 

Oblique imagery shown in a ―continuous‖ or ―Ortho‖ mode may suffer some distortion 

due to the irregularities of the terrain model that affects the ortho-rectification 

process. In flatter terrains the distortion is less. 

 

 

 

Tools are unselected when the view mode changes. Remember to select again the 

tool if using one when the mode is changed. 

 

There are five types of orientations: ―Ortho‖ orientation, that shows the image as 

an ortho-photo; ―North‖, that shows the image looking from south to north; 

―South‖, from north to south; ―East‖, from west to east; and ―West‖, from east to 

west. To change the orientation click in the ―O‖, ―N‖, ―S‖, ―E‖ or ―W‖ buttons in 

the upper left control to activate the ―Ortho‖, ―North‖, ―South‖, ―East‖ and ―West‖ 

orientations, respectively. 

 

 
 

The size of each view in the layout can be changed through the use of splitter 

bars between the views. Just move the mouse in the boundary of two views, and 

when the cursor changes, drag and drop the splitter to change the size of the 

views. Each time the size is changed this setting is saved in the user registry. 
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6.6 The intelligent behavior 

At closer zoom levels, oblique rectified images show big distortion on the 

buildings, while at furthest zoom levels they do not offer better information than 

the ortho images.  

Each view in the BlomURBEX Viewer is configured in an intelligent way so that 

any request that attempts to change the zoom level of the view will check if the 

view is displaying any orientation other than Ortho, and in this case decide what 

set of images should be displayed: ortho, oblique rectified or natural obliques. 

6.7 Changing basemap ortho image 

By default the ortho image shown as basemap is one from several images 

available in BlomURBEX server. These images are visible are certain resolutions: 

 Satellite images, with low resolution of the data. This source data is 

available in the furthest zoom levels (1 to 13), and contains Blue Marble and 

Landsat 7 imagery. 

 Countryortho is imagery covering a whole country (or a region). This 

source data is available in the medium zoom levels (13 to 19), and contains 

imagery from several providers and from Blom. 

 Blom imagery captured with Pictometry cameras, also called ―pictometry‖ 

images in the BlomURBEX server. This source data is available in the zoom levels 

with the maximum resolution (14 to 20). 

As can be seen at certain zoom levels these three sources coexist. For that zoom 

levels with more than one image available, the BlomURBEX server priorizes first 

the ―pictometry‖ image, then the ―countryortho‖, and finally, the ―satellite‖. It is 

possible to change this priority in the options. 
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In the textbox ―Baselayer priority‖ of the General tab of the Settings dialog, 

change the text to consider other priorities in the images for the basemap. For 

example, in the next screen capture, the left shows the default priority with the 

―pictometry‖ imagery by Blom in the zoom level 18, and the right shows a 

different priority that renders the ―countryortho‖ imagery, that is also available 

for that zoom level. 

 

 

Be careful to type the correct names in the Baselayer priority textbox, or no image 

will be shown. Type the names separated by commas and without any blank 

spaces. 

6.8 Showing the visible and total extension in Autodesk Map 

2010/2011/2012 

It is possible to see the visible and total extent of the opened BlomURBEX images 

drawn in Autodesk Map 2010/2011/2012. To do this follow this steps: 

 

1. In BlomURBEX Viewer, select the menu Settings > Open Settings dialog.  In the 

Settings dialog select the Linking tab. Ensure that checkbox ―Display image 

visible extent on linked mapping application‖ is checked for viewing the visible 

extent, and that checkbox ―Display image total extent on linked mapping 

application‖ is checked for viewing the total extent. Uncheck the checkboxes to 
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not update the extents in Autodesk Map 2010/2011/2012. The total extent only 

has sense when the view mode is ―photo by photo‖ also called ―Oblique‖ mode. 

 
2. Modify the visible extent of BlomURBEX Viewer by panning or zooming in the 

current image, or requesting other image. 

3. After a moment the boundaries will be drawn in Autodesk Map 2010/2011/2012. 

Boundaries are drawn using two layers in Autodesk Map 2010/2011/2012. By 

default visible extents are drawn in the color with index 3 in the current color 

table and total extents in the color with index 1. Modify this color indexes to show 

the extents in better colors. Ensure that the current colors do not match the 

background color or extents will not be visible. Also ensure that this layers in 

Autodesk Map 2010/2011/2012 are visible and are rendered using colors by 

layer. 

4. Another way to avoid the refresh of the visible an total extent, and also to avoid 

the refresh of the red crosshair with the center, is to set the apropiate layer to 

not visible in the Layer Properties Manager once this layers are added to the 

Autodesk Map drawing. 

 

6.9 Synchronizing views 

It is possible to synchronize the several views in the BlomURBEX layout, and 

synchronize the main view in BlomURBEX with the linked map in Autodesk Map 

2010/2011/2012. To do this follow this steps: 

1. Open the Settings dialog and select the Linking tab. 

 
To update Autodesk Map 2010/2011/2012 map center when BlomURBEX main 

view changes: 

2. The main view in BlomURBEX is one of the opened views. Depending on 

the layout the main view changes. The settings dialog marks which is the main 

view for each layout type. This view can be in sync with the linked map 

application. For it check the ―Center linked map at main view center‖. Now each 
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time the location of the BlomURBEX main view changes, the map will be 

refreshed to show that location. 

To update the main view in the BlomURBEX layout with Autodesk Map 

2010/2011/2012: 

3. The main view in BlomURBEX is one of the opened views. Depending on 

the layout the main view changes. The settings dialog marks which is the main 

view for each layout type. This view can be in sync with the Autodesk Map map. 

For it check the ―Center main view at linked map center‖. Now each time the 

center of the ―Autodesk Map‖ map changes, BlomURBEX main view will be 

refreshed to show that location. 

 

6.10 Seeing historical images from different years 

It is possible to show imagery for different years in each view, facilitating user to 

follow the changes occurred in a spot of the city. To do this, follow these steps: 

1. Open the Settings dialog and select the Layout tab. 

2. For the current layout, a set of textboxes for each view is shown in the 

dialog. Enter a year or a range of years, inside these textboxes to filter that view 

for a particular point in time. The date filter should follow one of these structures: 

YYYY-YYYY and YYYY, where YYYY is the year number with four digits. 

3. For example: ―2005-2008‖ will return the most updated image available 

inside the range of years, including both bounding years. In this example, if an 

image of 2007 is available and no image in 2008 is available, then the image of 

2007 is returned. But if no image is available between 2005 and 2008, and only 

an image of 2009 is available, then no image will be returned. 

4. Another example: ―2006‖ will return the most current images available, 

whose date is previous to the requested date. In this case if several images are 

available previous to the year 2006 or from that year, then the last one will be 

returned. 

5. If the default value is empty, then the most updated image will be 

requested. 

6. If a wrong value is sent, then no image will be returned. 

7. The settings will affect also the Extract image or Export image tools when 

applied to the views with a date filter. 
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Above both views of Eiffel tower from 2008 and 2009 

 

 

The option to change the date of the BlomURBEX images allows to see side by side 

the same part of a city in different years. Up to five different years could be shown 

at a time. Just select the same view mode and orientation, and explained below, 

for each view in a multi-view layout, but choose different years for each view. 
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7 Obtaining image information 

To obtain the information about the current opened image, click in the Image 

Properties button in any status bar of the views. A panel will open showing extent 

coordinates in WGS84 lon/lat for the full image (in obliques) and for the visible 

portion and other data if available. To hide the panel click again in the button. 

 
Info in ortho view 

 
Info in oblique view 

To copy the image data just select the text in the panel, click the right mouse 

button, select copy, and paste it anywhere. 
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8 Using the measurement tools 

BlomURBEX Viewer offers various tools for measuring features visible in images. 

For example, it is possible to measure the distance between two points, the 

elevation of the terrain, building heights, bearing, area, perimeter, and the 

coordinates of a point. 

Before using the measurement tools, be sure that the unit of measure is set as 

desired.  

8.1 Changing units of measure 

To change units of measure: 

1. In BlomURBEX Viewer click the menu Settings > Open Settings dialog. The 

Settings dialog box opens. 

2. In the General tab click the desired units: Meters or Feet. 

3. Click OK. 

The changes remain in effect until units are changed again. 

8.2 Viewing the coordinates of a location 

Use the Location Tool to determine the location (the coordinates) of an object in 

an image both in ortho or oblique views. 

To determine the location of an object: 

1. In BlomURBEX Viewer click the Location Tool . 

2. Click the desired location on the image. 

3. The point’s coordinates appear drawn in the view. If the projection selected in 

the Settings dialog is not Spherical Mercator, the same coordinates will be 

seen in both systems, Spherical Mercator and the selected one, in the desired 

units, meters or feet. 

 

 

For Oblique images, remember to click near the base of buildings for more 

accurate coordinates. 
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8.3 Measuring squared perimeter or distance 

Use the Distance Tool to measure perimeter—the distance around the outside 

edge of an object or distances both in ortho or oblique views. 

To measure perimeter by using a parallelogram or measure distances: 

1. Click the Distance Tool . 

2. Starting with one corner of the object, click with the left mouse button. 

3. Click again for each new vertex. The outline of a polyline appears as new 

vertexes are added. In oblique mode take in mind that a workaround to the 

server must be done in each vertex, and the measure takes longer. 

4. When the polyline surrounds the shape being measured or distance being 

measured, double click with left mouse button. 

5. The partial measurements and total length appears drawn in the view. 

 

8.4 Measuring bearing 

Use the mouse to draw one line to measure bearing both in ortho or oblique 

views. Where start drawing the line is important, as shown in the following 

illustrations: 
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To measure bearing: 

1. Click the Bearing Tool . 

2. Click with the left mouse button on the starting point. 

3. Click with the left mouse button on the ending point in the direction you 

want to measure the bearing of. The measurement appears drawn in view. 

 

8.5 Measuring area 

The Area Tool lets to measure the area of any linear shape both in ortho or 

oblique views. After the perimeter of the area to be measured is outlined, the 

area measurement appears in view. 

To measure the area of any straight-sided shape: 

1. Click the Area Tool . 
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2. Click in the display at the desired starting point. 

3. Click again for every new vertex of the area. A polygon that returns to 

initial point is drawn automatically. 

4. When outlined the entire perimeter, double click in the last vertex. 

 

8.6 Measuring height 

Use the Height Tool to measure the height of an object in an Oblique image. 

(Because Orthogonal images are captured straight down, the Height Tool doesn’t 

apply to the ―continuous‖ or ―Ortho‖ view mode.) 

To measure height: 

1. Click the Height Tool . 

2. Click with the left mouse button on a point at the base (where it meets the 

ground) of the object we want to measure the height of. 

 

 

Important: Be sure to measure height by starting at ground level and moving 

upwards. If the ground level starting point is not seen, then estimate its location. 

 

3. Move the mouse upwards and click a new vertex at the ending point. 
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4. The measurement appears drawn in view. 

8.7 Measuring elevation 

Use the Elevation Tool to measure the elevation (height above sea level) of a 

point in an image. 

To measure the elevation: 

1. Click the Elevation Tool . 

2. Click the point whose elevation to measure. 

3. The measurement appears drawn in view. 

 

8.8 Clearing measurements 

Use the Eraser Tool to clear measurements in the map display. 

To clear measurements: 

1. Click the Eraser Tool . 

2. The measurements are removed in all available views. 

 

 

 

 

 

 

 

Start measuring 

here. 

Finish measuring 

here. 
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9 Printing images 

BlomURBEX Viewer let print all the views opened to the selected printer, setup 

the page options and preview the printing, along with the image properties if they 

were activated in the settings dialog. Before printing, scroll or pan the image so 

that the portion we wish to print is visible in the display. Also resize the views 

with the splitters and the size of the BlomURBEX Viewer window. The visible 

portion of each image, and with the exact pixel size, will be send to printer. 

9.1 Printing images 

To send all the current views to the printer with the current settings: 

1. Click the File > Print menu. 

 
2. The views are printed. 

Each view in the layout is printed in different pages also with the image 

information activated in settings. If the image information is longer than the page 

space, it will be cropped. In this case, try reducing the size of the BlomURBEX 

Viewer views or window, or limit the amount of information to print in settings 

dialog, as explained below. 

9.2 Changing print settings 

To change the printing settings: 

1. Click the Settings > Open Settings dialog menu. 

2. The settings dialog opens. Select the Printing tab. 

3. Check or uncheck the options wanted. 

4. ―Display image properties‖ adds the corner coordinates of the image to the 

output (if the image is a oblique one) and other properties. 

5. ―Display the visible extension of the image‖ adds the corner coordinates of 

the visible portion of the image. 

6. ―Display shot date‖ adds to the output the shot date of the image. 

7. Click OK in the Settings dialog to save changes. 
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9.3 Page setup 

 

To change page settings: 

1. Click the File > Page setup menu. 

 
2. The Page setup dialog opens. Modify the page margin, orientation, etc. as 

desired. Click OK to accept changes. 

 

9.4 Print preview 
 

To preview the print: 

1. Click the File >Print preview menu. 
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2. The Print preview dialog opens. Click in the options to see the print at different 

zooms o layouts. Also it is possible to print clicking in the Print button. The dialog 

can be resized to full screen. 

 

The image shows the preview of a dual view layout. Each view and its properties 

are print in different pages. 
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10 Exporting images 

10.1 Exporting all visible views 

The BlomURBEX Viewer ―Export image‖ menu lets exporting the visible extent of 

the active views to a set of JPG files. 

To export an image: 

1. Pan in the views to display the extent desired. 

2. Click the ―File > Export image…‖ menu. 

3. In the Save as dialog that opens introduce the path and filename for the 

file. 

The extracted image or images are saved with the filename specified. If the 

BlomURBEX layout shows several views, then several files will be created and all 

the files will be suffixed with a view number and orientation. Also, if view is in 

ortho mode, a world file (JGW) is saved for easy integration of the image in other 

GIS packages. 

 

10.2 Projection of the extracted ortho images 

The projection of the extracted ortho images are ―Spherical Mercator‖, the 

projection labelled by EPSG as 'Popular Visualisation CRS / Mercator' in March 

2008 with code number 3785. Due to limited support to this projection in 

Autodesk Map 2010/2011/2012 version, a transformation of the exported images 

using other software would be necessary to open them in Autodesk Map 

2010/2011/2012. 
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11 Saving measurements 

BlomURBEX Viewer is able to notify when the user has made measurements in 

order to store this measures into any opened table in Autodesk Map 

2010/2011/2012. 

11.1 Setting measurement savings 

To activate the measurement storage, it is needed to complete two one-time 

setup tasks. It is needed to specify some options about the place where store the 

measurements, and some options about the units and the projection to use (in 

the case the measurements are locations). 

To specify the options regarding the place to store measurements: 

1. Click in the ―Center in new map point‖ button once. When this button is clicked, 

the Saving options are updated for the current drawing opened. 

2. Click in the Settings > Open Settings dialog menu. 

3. The Settings dialog opens. Select the Saving tab. 

4. Select a mode for saving measurements from the Table dropdown list. The 

options for saving measurements are: ―<Save as text>‖, that inserts a text with 

the measure; ―<Save as dimension>‖, that creates a dimension (only has sense 

for linear or angular measurements); ―<Save as attribute>‖, that creates a block 

with the measurements as attributes; ―<Save as extrusion (only for Heights)‖, 

that saves the measurements as Z values inside the geometry (only has sense for 

height measurements) ; finally, the rest of options represent the object data 

table names contained in the Autodesk Map drawing. 

 

 
5. Each option of the Table dropdown list populates different sub-options in the 

Column dropdown lists: 
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 For ―Save as text‖ mode, only a ―<Save as text>‖ option is given. Select this 

sub-option for that type of measurements you want to save as texts, and 

leave as ―<None>‖ for those measurements not to be saved.  

 For ―Save as dimension‖ mode, two sub-options (Linear dimension and 

Angular dimension) are given. Select ―Linear dimension‖ for distances and 

heights measurements, and select ―Angular dimension‖ for bearing 

measurements, because for the other type of measurements this saving has 

no sense.  

 For ―Save as attribute‖ there are multiple sub-options, one per each type of 

measurement. In this last case the sub-options represent names for blocks 

and attributes that will be added to drawing for storing the measurements.  

 For ―Save as extrusion (only for heights)‖ mode, only a sub-option ―Save as 

extrusion (only for heights)‖ is given. Select this sub-option for height 

measurements only. This option will extrude one or several region objects 

selected. 

6. As seen in the screenshot, it is possible to select a sub-option from the dropdown 

lists for each type of measurement to save. It is possible to store seven different 

type of measurement. The table summarizes the relation between the 

BlomURBEX Viewer tools and the Column dropdown used to make the savings. 

 

IInn  BBlloommUURRBBEEXX  VViieewweerr  

tthhee  ttooooll  uusseedd  iiss  ......  

IInn  AAuuttooddeesskk  MMaapp  22001100//22001111//22001122  mmeeaassuurreemmeennttss  aarree  

ssaavveedd  iinn  tthhee  ffiieelldd  sseelleecctteedd  iinn  ddrrooppddoowwnn......  

 Column for areas 

 Column for distances 

 Column for heights 

 Column for elevations 

 Column for X coords and Y coords 

 Column for bearings 

 

7. To store only some measurements, select <None> for those 

measurements in the dropdown lists. 

8. Click in OK to save settings. 

To specify the options regarding the units and the projection to use in locations: 

1. Click in the Settings > Open Settings dialog menu. 

2. The Settings dialog opens. Select the Saving tab. 

3. Select the desired units, meters or feet. The values will be stored in the 

units selected. 

4. Select the Linking tab. 

5. In the ―Save location measurements‖ groupbox, choose ―in Spherical 

Mercator projection‖ for storing location data in Spherical Mercator meters in 

Autodesk Map 2010/2011/2012, or choose ―in selected map projection‖, more 
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usual, for storing location data in the projection of the current map in Autodesk 

Map 2010/2011/2012. This setting only affects the Location tool. 

6. Click OK to save settings. 

 

11.2 Starting and stopping save sessions 

In BlomURBEX Viewer it is possible to start, pause and continue the savings 

through an option. 

To start a save session: 

1. Click in the ―File > Start saving measurements‖ menu if it is unchecked. 

The menu will toggle to a checked state and measurements will be stored (if 

fields were correctly set). 

To pause a session: 

1. Click in the ―File > Stop saving measurements‖ menu if it is checked. The 

menu will toggle to an unchecked state and measurements will be paused. 

 

11.3 Procedure for saving measurements 

The procedure for saving measurements is this: 

1. Ensure that the ―Start saving measurements‖ menu is checked so the text in the 

menu is now ―Stop saving measurements‖. 

2. Now in BlomURBEX Viewer do a measurement as described in this manual. A 

message to confirm the saving appears, informing about the measurement that is 

going to be saved, and the method and sub-option to be used. Click Yes to 

proceed. 

3. An input box appears, for methods ―Save as text‖, ―Save as dimension‖ and 

―Save as attribute‖, to define a text height in map units that will be used to draw 

texts in Autodesk Map. Type a height value and click OK. 

4. Click in the map display to activate the Autodesk Map commands. 
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5. If the mode for saving was ―Save as text‖, the user will be prompted for a point 

where to insert the text. Enter a known coordinates and press Enter or click a 

point in the map. 

6. If the mode for saving was ―Save as dimension‖ and the sub-option was ―Linear 

dimension‖, the user will be prompted for a point where to start creating the 

dimension. Enter a known coordinates and press Enter or click a point in the map. 

Next the user will be prompted for a point where to finish creating the dimension. 

Enter a known coordinates and press Enter or click a point in the map. Finally the 

user will be prompted for a point where to position the dimension. Enter a known 

coordinates and press Enter or click a point in the map.  

7. If the mode for saving was ―Save as dimension‖ and the sub-option for storing 

measurements was ―Angular dimension‖ then the user will be prompted for a 

point where to position the vertex of the angular dimension. Enter a known 

coordinates and press Enter or click a point in the map. Next the user will be 

prompted for a point for the first reference point. Enter a known coordinates and 

press Enter or click a point in the map. Next the user will be prompted for a point 

for the second reference point. Enter a known coordinates and press Enter or 

click a point in the map. Finally the user will be prompted for a point where to 

position the dimension. Enter a known coordinates and press Enter or click a 

point in the map. 

8. If the mode for saving was ―Save as attribute‖ the user will be prompted for a 

point where to position the block with an attribute. Enter a known coordinates 

and press Enter or click a point in the map. 

9. If the mode for saving was ―Save as an extrusion‖ the user will be prompted to 

select one or several region objects. Select the objects you want to extrude and 

press Enter. To see the result of the extrusion, you should change the view of the 

map to a 3D viewport. 

10. If the mode for saving was to save in a data object table the user will be 

prompted to select one or several drawing objects. Select the objects you want to 

have a data object inserted with the measurement and press Enter. If the table 

and field selected in BlomURBEX Viewer settings are no more defined in the 

current Autodesk Map drawing then a warning message will appear. In this case 

change the Viewer settings and try again saving the measurement. 

 

11.4 Example: how to extrude features to 3D 

In this example, the saving measurements capabilities will be used to extrude 2D 

features (buildings), to convert them to 3D features using the Height 

measurement tool. Follow the steps below: 

1. Open Autodesk Map 2010/2011/2012 and a dwg file with 2D features. 

2. Features to be extruded must be regions, so if it not the case, select the Draw > 

Region command, or the Region tool from the Draw toolbar in Autodesk Map. 

Then select the features to be converted to regions and press Enter. When doing 

this be aware that the new feature is added to the active layer. 
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On the left the building footprints (orange) before converted, drawn as polylines, 

and on the right, after using Region tool (white). 

3. Tilt the view using the View > 3D Orbit menu to better appreciate the 3D 

conversion. 

 
4. Open the BlomURBEX viewer if it was closed. Click in ―Center in new map point‖ 

button and select a point in the map in the middle of the zone of interest. Switch 

to a oblique view. If view does not switch to any oblique view, check the 

―intelligent behaviour‖ and zoom in to closer zoom level, and then retry changing 

to any oblique view modes (North, South...). When the city buildings are best 

viewed, and then proceed to next step. 
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5. Change ―Saving‖ settings in the Settings dialog as previously indicated. In the 

Settings dialog set the table name to ―<Save as extrusion (only for heights)>‖, 

and in the column for heights dropdown box select ―<Save as extrusion (only for 

heights)>‖. 

6. Check the File > Start saving measurements in BlomURBEX viewer toolbar to 

initialize saving session. 

7. Select the Height tool. Measure heights in the buildings. Each height measured a 

message box appears with information about the measure to be saved. Click Yes 

to proceed. Then select the feature or features to extrude. Finally press Enter. 

The selected features are extruded. 
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12 Overlaying tile raster data 

BlomURBEX Viewer is able to overlay tile raster data from BlomURBEX server, 

both in ―Ortho‖ and ―Oblique‖ modes. In next chapter is explained how is possible 

to overlap also local vector data loaded in Autodesk Map 2010/2011/2012. Both 

tile raster layers and local vector layers can be overlapped at the same time over 

the BlomURBEX Viewer. They all are treated as layers and drawn on top of the 

basemap imagery. 

12.1 Activating and deactivating raster overlays 

To activate or deactivate the raster overlays follow these steps: 

1. Click in the Settings > Open Settings dialog menu. 

2. Select the Overlays tab. 

3. Each time the settings dialog in opened, a query is done to the 

BlomURBEX server to return the available tile layers for the current user. 

Remember when changing the UserToken option to close the dialog clicking OK 

button and to open again the dialog, because each UserToken has permission for 

different tile layers depending on user restrictions. Indeed, it is possible for a 

customer to host his vector data at BlomURBEX through a rasterization process. 

 
4. Select one or several layers from the list ―Tile layer to overlay from 

server‖. Click once to select and once again to deselect. 

5. Click OK to save the setting and start overlaying or clean overlays. This 

setting is not saved in user registry for better performance initialization. 

BlomURBEX Viewer always start with the setting unselected. It is needed to set it 

explicitly in each BlomURBEX Viewer session. 
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Tile 

raster overlay with TeleAtlas streetmap 
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13 Overlaying vector data 

BlomURBEX Viewer is able to overlay vector data from Autodesk Map 

2010/2011/2012 on top of BlomURBEX imagery, both in ―Ortho‖ and ―Oblique‖ 

modes. 

13.1 Activating and deactivating vector overlays 

To activate or deactivate the vector overlays there are two options with the same 

result: 

1. Click in ―Overlay vector layers over BlomURBEX imagery‖ button in the 

BlomURBEX toolbar .  

OR 

2. Click in the Settings > Open Settings dialog menu. 

3. Select the Overlays tab. 

 
4. Check or uncheck the ―Overlay vector layers over BlomURBEX imagery‖ checkbox 

to activate or deactivate overlays, respectively. 

5. Click OK to save the setting and start overlaying or clean overlays. This setting is 

not saved in user registry for better performance initialization. BlomURBEX 

Viewer always start with the setting uncheck. It is needed to set it explicitly in 

each BlomURBEX Viewer session. 
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Overlying on top of oblique imagery may be a long time operation. Be patient 

when overlaying a big number of features over oblique images. Read below for 

tricks to improve performance. 

13.2 Refreshing vector overlays 

When Overlay option is activated the existing layers in the opened DWG in the 

Autodesk Map 2010/2011/2012 map display are added to BlomURBEX views. 

Layers added through a connection to SHP, Oracle or other data providers are not 

overlapped. They need to be inserted in a DWG file in order to be overlapped. If a 

new layer is added or any feature is modified in its geometry after activating the 

Overlay option, these changes are not shown immediately. To reflect these 

changes is needed to click in the ―Reload overlays‖ button in the BlomURBEX 

Viewer toolbar . This function again adds the layers to BlomURBEX; cleans all 

the overlays and redraws the vector data again. 

 
Before Refreshing Vector Overlay 
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After Refreshing Vector Overlay 

 

 

When overlaying vector data in oblique imagery, remember that vertexes of the 

geometries should match with the imagery at the ground level, not at the roof level. 

That is the reason of the apparent offset seen when overlapping over oblique 

imagery. 

 

13.3 Overlay and performance considerations 

To overlap geometries faster, a combination of requests to BlomURBEX server 

and local interpolations is done. It is possible to adjust the precision of the 

interpolations. 

For that, follow these steps. 

1. Open Settings dialog. 

2. Select the Overlays tab. 

3. The amount of points used for the interpolation determines the accuracy. 

It is possible to use no less than four points and no more than 400 points. 

Change this clicking up or down the ―Points of interpolation‖ textbox. More points 

interpolates more accurately but is slower. Default is 100. 
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When Overlay option is activated only visible features inside the visible extent are 

sent from Autodesk Map 2010/2011/2012 to BlomURBEX Viewer and rendered on 

top of BlomURBEX imagery. Try to limit the amount of features to be sent or the 

BlomURBEX Viewer performance will decrease when overlapping imagery. To limit 

the number of features follow this advices: 

1. Remove those layers that do not contain entities, or that contain blocks or 

references. Blocks and references are ignored when overlapping. If the drawing 

contains a big number of temporary layers, blocks, and references, consider the 

creation of a new version of the drawing using only the entities that can be 

overlapped. 

2. Use DWG format better than DXF format. 

3. Use Color ByLayer and Line Type ByLayer. This has a great impact in 

performance. BlomURBEX viewer is optimized to show GIS-like vector data, that 

uses one style per layer, instead of CAD-like vector layer, where each entity can 

be drawn with different style properties. 

4. Hide in Autodesk Map 2010/2011/2012 those layers that are not relevant. 

5. Zoom in inside ―Ortho‖ BlomURBEX views so the visible extent contains a 

small number of features. Only features that fall inside the visible extent are 

overlaid. The zoom level is not a consideration in ―Oblique‖ mode. 

13.4 Symbology limitations 

The BlomURBEX Viewer has less symbology properties than Autodesk Map 

2010/2011/2012. These are the limitations of the current version: 

 

1. Only Autodesk Map 2010/2011/2012 entities that support the LightWeightPolyline 

interface are sent to BlomURBEX. For example, ellipse or circle elements are not 

drawn in BlomURBEX. Arcs entities are treated as straight lines, and the curved 

lines are not preserved. Each element in the drawing is draw with its own color 

and width, or the Layer one if the element has the ByLayer color and width. 

2. Points are visible. 

3. Polylines supported are always shown as solid lines, but the width and color are 

correctly chosen. 

4. Polygons and the rest of Autodesk Map 2010/2011/2012 entity types are not 

supported.  
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14 Uninstalling BlomURBEX plug-in for Autodesk Map 
2010/2011/2012 

To uninstall follow these steps: 

 

1. In the Windows Control Panel, open the ―Add/Remove programs‖, select 

BlomURBEX plug-in for Autodesk Map 2010/2011/2012 and uninstall, following 

the guidelines.  
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15 Troubleshooting 

15.1 Log files 

If the applications do not work as expected, the best way to know what is 

happening is to activate the logging utility. 

In BlomURBEX Viewer, to activate logs, open the Settings dialog, and in the 

General tab, select the desired level for logs. A log file or several, one per 

process, will be created in the [User Application Data] \ BlomURBEX2D folder 

(usually c:\ Documents and Settings \<username>\Application 

Data\BlomURBEX2D). To deactivate logs just select None as log level. To activate 

logs select Error, Warning, or Information level (in order from minimum to 

maximum verbose).  

 
Log files offer the time and some information about events that occur in the 

applications that can help to solve some problems. Otherwise, if the problem is 

not known, send the log files with your comments to Blom Technical Support to 

help in fixing the problem. You can use the menu ? > Send feedback to send an 

email. 
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15.2 Cache directory 

The BlomURBEX Viewer creates a cache folder stored in ―[User Application Data] \ 

BlomURBEX2D \ cache‖ folder (usually c:\ Documents and Settings 

\<username>\Application Data\BlomURBEX2D\cache). This cache folder store 

tiles for faster retrieve of them. 

To avoid this folder to resize to a big amount of bytes, it is possible to delete its 

contents periodically. Deleting the cache folder also ensures that the last tiles are 

downloaded. 

To delete the cache click in the Delete cache button from the General tab of the 

Settings dialog, or just delete its content from Windows Explorer. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 
BlomURBEX™ Plug-in for Autodesk Map 2010/2011/2012 v3.0.0 

 

 57 

Blom, ASA. Proprietary 

16 Frequently Asked Questions 
 

1. Why I do not see the visible and total extent of images in Autodesk 

Map 2010/2011/2012? 

Ensure checkboxes in ―Linking‖ tab of BlomURBEX Viewer Settings dialog are 

checked. 

 

2. Why the point I select in Autodesk Map 2010/2011/2012 is not 

exactly the same in the image in BlomURBEX Viewer? 

The data opened in Autodesk Map 2010/2011/2012 can be in any coordinate 

system. When digitizing this data, a coordinate system was used, defined by 

some parameters that describe the Earth and how to convert between 

projections. BlomURBEX Viewer uses the DotSpatial library to perform 

transformations between any projection and Mercator Spheric (EPSG: 3785), the 

default projection that use BlomURBEX Web Services at the moment. If the 

parameters used by the operator that digitizes the data opened in Autodesk Map 

2010/2011/2012 and the parameters used in DotSpatial are not the exactly the 

same, some shift can occur in the location. In order to minimize this shift, it is 

possible to modify the epsg file that comes in the BlomURBEX install dir. The 

parameters must comply with the rules that expect DotSpatial (PROJ4 format). To 

know more about this, check the appendix below. 

 

3. Why the measurements are not saved in Autodesk Map? 

The requirements to save measurements in Autodesk Map are the following. If 

any of this requirements are not fulfilled the saving will not takes place. 

 In the BlomURBEX Viewer settings dialog a table and a field must be selected 

for the desired measurement type. To store heights, the correct dropdown box 

with the field for heights must be selected, for example. If the dropdown has 

<None> selected that measurement will be ignored. 

 The ―File > Start saving measurements‖ menu must be checked. 

 

4. Why SHPs or other data do not appear when overlapping? 

These data need to be transferred to the current opened DWG in order to be 

overlapped. 
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17 Appendix A: how to add new projections 

The projection support relies on the DotSpatial public domain library. In the 

installation folder of BlomURBEX Viewer a file ―epsg‖ is provided that contains 

EPSG codes, names and parameters for the EPSG coded projections. If you need 

to modify an existing projection, or to add support for new projections, modify 

this file with any text editor following the DotSpatial (Proj4) rules for parameters. 

See the http://proj.maptools.org/ webpage for more information. 

For example, if support for the Microsoft Live Maps projection is needed, add the 

next two lines to the file (the second line looks longer but is only one): 

# World Mercator 

<54004> +proj=merc +lat_ts=0 +lon_0=0 +k=1.000000 +x_0=0 +y_0=0 

+ellps=WGS84 +datum=WGS84 +units=m  no_defs <> 

Or support for Google Maps projection: 

#Google 

<900913> +proj=merc +a=6378137 +b=6378137 +lat_ts=0.0 +lon_0=0.0 

+x_0=0.0 +y_0=0 +k=1.0 +units=m +nadgrids=@null +wktext  +no_defs <> 

For optimize the Select projection dialog, delete from the ―epsg‖ file any 

projection not needed. Remember that each projection in the file uses two lines, 

so do not break the format of this file or BlomURBEX Viewer could not work 

correctly. 

Once the ―epsg‖ file is modified, open again the Settings dialog in BlomURBEX 

Viewer and reselect again the projection to refresh internal BlomURBEX settings. 

 

 

 

 

 

 

 

 

 

http://proj.maptools.org/
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18 Appendix B: how to improve interface translation 

BlomURBEX Viewer interface supports twelve languages. The strings for each 

language are stored in the registry, in the path HKEY_LOCAL_MACHINE / 

SOFTWARE / Blom / Urbex 2.0. Each language has a section: english (en), 

español (es), deutsch (de), français (fr), italiano (it), nederlands (nl), portugués 

(pt), dansk (da), norsk (no), svenska (sv), suomi (fi), româna (ro). 

Each string uses a pair name-value. The name is an easy-to-understand name. 

For example, ―AboutBoxForm.Description‖ is the description for BlomURBEX 

Viewer that appears in the About dialog. Change these values at your 

convenience using the registry editor. Next time you open BlomURBEX Viewer will 

reflect your changes. If any value is missing, the default value used is the English 

string. 

If you found wrong strings in your language and want to help us improve the 

software, feel free to send us an export of the registry language settings to the 

Blom Technical Support email using? > Send feedback menu in BlomURBEX 

Viewer. 

 


